UTS Library

Browse Questions

ENX7Update.msp missing

Hi there!

I downloaded and used Endnote last semester, but when I went to open it the other day, it tries to go through a whole install process.  It wants me to find 'ENX7Inst.msi' on my computer but couldn't find it.

In order to fix the situation, I thought to reinstall Endnote via the links on the UTS Library website.  I am successfully downloading EndNoteX7.zip but the link to the update file ENX7Update.msp takes me to a page indicating that the file is missing.

 

I am running Windows 10 ... is this a problem encountered by other students / users?

 

Hope to be able to get it up and running shortly !

 

Cheers

Vicky

5 answers
29364 views

Answers

Hi Vicky,

D Litting's picture
D Litting, 1 year ago

Hi Vicky,

 

I found this on a Microsoft user forum. I think this problem isn't EndNote specific (it's more about that kind of file extension) so I hope this works but if not let me know. Perhaps if your computer is mobile and you are able to come into the library you could do that and we could see if we can make things right for you

My contact details are here if you need them - david.litting@uts.edu.au / 95143390. I'll cut and paste the potential fix below:

 

To Update this thread, this is a known issue for which this fix works in most cases.  If not it tells you what further to do: 

 

Right click task bar to open Task Manager.  If necessary show More Details

 

On Details tab look for msiexec.exe, highlight to End Task.

 

Now try install or uninstall again.

 

If this doesn’t help you can try to repair Windows Installer using the script at Repair MSI (Windows Installer) - MajorGeeks

 

This can be symptomatic of corruption.  I would go over the integrity of your install by working through the steps forWindows 10 Performance Troubleshooting - Microsoft Community .

Hi Vicky,

D Litting's picture
D Litting, 1 year ago

Hi Vicky,

I know that there have been problems with Windows 8 opening MSI files, which affects Endnote (there are workarounds for that problem happily). It's possible there are similar issues with Windows 10, but I'll have to do a little bit of looking around to see if I can figure out the solution. 

I'll respond again soon on this page once I've figured out what the problem might be,

Thanks!

David

Hi David

Victoria's picture
Victoria, 1 year ago

Hi David

Thank you so much for investigating into my EndNote (and windows 10) problem - with windows 10 it has been a case of issue after issue ...!

It also said I was missing some other .dll files which after some forum and google searching persuaded me to redownload and install the microsoft visual whateveritwas

Anyway, I got around it by re-downloading and re-installing EndNote X7.  It then prompted me to download the update, the link to which was 'missing' on the library website.  

 

Its all working now !   Now I just have to brush up on my skills on navigating around EndNote and tapping into its functionalities.

 

Thanks so much again!

 

Cheers

vicky 

No worries Vicky, well done

D Litting's picture
D Litting, 1 year ago

No worries Vicky, well done on finding your solution. Hopefully things will run smoothly now, EndNote is a fun and pleasurable thing to use once it's up and running so I think your perseverance will be rewarded :) 

David

Answer question